const regex = /email=(\w+@\w+\.\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('email=(\\w+@\\w+\\.\\w+)', 'g')
const str = `www.website.com/?email=test@gmail.com
www.website.com/?email=test@gmail.com&name=john
www.website.com/?name=john&email=test@gmail.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}