#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<\/?([a-zA-Z][a-zA-z0-9]+)[^>]*>(\s|[\w\W])+?<\/?\1>"
Local $sString = "<script>" & @CRLF & _
" function header(){" & @CRLF & _
" var x = 8;" & @CRLF & _
" var y = 10;" & @CRLF & _
" return x + y;" & @CRLF & _
" }" & @CRLF & _
"</script>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")