use strict;
my $str = '<script>
function header(){
var x = 8;
var y = 10;
return x + y;
}
</script>';
my $regex = qr/<\/?([a-zA-Z][a-zA-z0-9]+)[^>]*>(\s|[\w\W])+?<\/?\1>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}