$re = '/<\/?([a-zA-Z][a-zA-z0-9]+)[^>]*>(\s|[\w\W])+?<\/?\1>/m';
$str = '<script>
function header(){
var x = 8;
var y = 10;
return x + y;
}
</script>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);