const regex = /^\w{2,5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w{2,5}$', 'gm')
const str = `12345`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);