use strict;
my $str = '12345';
my $regex = qr/^\w{2,5}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";