# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(")(?![^<>]*>)/<tag>$1<\/tag>/gm;t' <<< "I want to replace the \" caracter, ignoring<span id=\"ID\"> that \"-ones inside </span> the \"HTML tags\" to apply some tags"