#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(")(?![^<>]*>)"
Local $sString = "I want to replace the " caracter, ignoring<span id="ID"> that "-ones inside </span> the "HTML tags" to apply some tags"
Local $sSubst = "<tag>$1</tag>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)