import re
regex = re.compile(r"(\")(?![^<>]*>)", flags=re.MULTILINE)
test_str = "I want to replace the \" caracter, ignoring<span id=\"ID\"> that \"-ones inside </span> the \"HTML tags\" to apply some tags"
subst = "<tag>$1</tag>"
result = regex.sub(subst, test_str)
if result:
print(result)