const regex = /(?s)^.*?regex\K.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)^.*?regex\\K.*', '')
const str = `some text for test and need to replace by regex using php
We have another sentence`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}