$re = '/(?s)^.*?regex\K.*/';
$str = 'some text for test and need to replace by regex using php
We have another sentence';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);