re = /(?s)^.*?regex\K.*/
str = 'some text for test and need to replace by regex using php
We have another sentence'
# Print the match result
str.match(re) do |match|
puts match.to_s
end