package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(\w{6})\b`)
var str = `японский программист Юсукэ Эндо (Yusuke Endoh)
японский программист Юсукэ Эндо (遠藤 侑介)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}