# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(((?:[AB](?=0[2-9]|1[0-5]))))[0-9]{2}(?:(?=,\s*\2),|))*/$1$2/gmix;t' <<< "I have a line XX,VV,A01,A02,A03,A11,A12,A13,A14,B11,B12,B13,ZZ,DD
I need a regular expression for
If I find A01,A02,A03 or A11,A12,A13,A14 in my line, I have to replace with \"AA\"
If I find B11,B12,B13 I have to replace with \"BB\"
I have tried using
if (Regex.IsMatch(Value, \"^A0[2-9]\")|| Regex.IsMatch(Value, \"^A1[0-5]\"))
It didnt work -- so basically if i have A02,A03, A04, A05, A06, A07 or A10,A11,A12....... A15 , I have to replace with \"AA\""