# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:(((?:[AB](?=0[2-9]|1[0-5]))))[0-9]{2}(?:(?=,\s*\2),|))*
"""
test_str = ("I have a line XX,VV,A01,A02,A03,A11,A12,A13,A14,B11,B12,B13,ZZ,DD\n\n"
"I need a regular expression for\n\n"
"If I find A01,A02,A03 or A11,A12,A13,A14 in my line, I have to replace with \"AA\"\n"
"If I find B11,B12,B13 I have to replace with \"BB\"\n"
"I have tried using\n\n"
"if (Regex.IsMatch(Value, \"^A0[2-9]\")|| Regex.IsMatch(Value, \"^A1[0-5]\"))\n"
"It didnt work -- so basically if i have A02,A03, A04, A05, A06, A07 or A10,A11,A12....... A15 , I have to replace with \"AA\"")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.