#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mix)(?:(((?:[AB](?=0[2-9]|1[0-5]))))[0-9]{2}(?:(?=,\s*\2),|))*"
Local $sString = "I have a line XX,VV,A01,A02,A03,A11,A12,A13,A14,B11,B12,B13,ZZ,DD" & @CRLF & _
"" & @CRLF & _
"I need a regular expression for" & @CRLF & _
"" & @CRLF & _
"If I find A01,A02,A03 or A11,A12,A13,A14 in my line, I have to replace with "AA"" & @CRLF & _
"If I find B11,B12,B13 I have to replace with "BB"" & @CRLF & _
"I have tried using" & @CRLF & _
"" & @CRLF & _
"if (Regex.IsMatch(Value, "^A0[2-9]")|| Regex.IsMatch(Value, "^A1[0-5]"))" & @CRLF & _
"It didnt work -- so basically if i have A02,A03, A04, A05, A06, A07 or A10,A11,A12....... A15 , I have to replace with "AA""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)