# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d)\//0$1\//gm;t' <<< "1/1/2012
1/12/2012
1/1/2012"