use strict;
my $str = '1/1/2012
1/12/2012
1/1/2012';
my $regex = qr~\b(\d)/~mp;
my $subst = '0$1/';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";