$re = '~\b(\d)/~m';
$str = '1/1/2012
1/12/2012
1/1/2012';
$subst = "0$1/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;