using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*[^*]*\*+([^\/*][^*]*\*+)*\/";
string input = @".class-n {
}
/* I want to select everything but these comments */
.class-1 {
font-family: 'SourceCodePro';
font-size: 16px;
line-height: 18px;
}
/* I want to select everything but these comments */
.class-2 {
background-color: rgb(40, 40, 40);
border: 1px solid rgb(20, 20, 20);
padding: 10px 15px 10px 15px;
}
/* Single line */
/* Multiline
Comment */
Some text here";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}