re = /\/\*[^*]*\*+([^\/*][^*]*\*+)*\//
str = '.class-n {
}
/* I want to select everything but these comments */
.class-1 {
font-family: \'SourceCodePro\';
font-size: 16px;
line-height: 18px;
}
/* I want to select everything but these comments */
.class-2 {
background-color: rgb(40, 40, 40);
border: 1px solid rgb(20, 20, 20);
padding: 10px 15px 10px 15px;
}
/* Single line */
/* Multiline
Comment */
Some text here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end