# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/\*[^*]*\*+([^\/*][^*]*\*+)*\/"
test_str = (".class-n {\n\n"
"}\n\n"
"/* I want to select everything but these comments */\n\n"
".class-1 {\n"
" font-family: 'SourceCodePro'; \n"
" font-size: 16px;\n"
" line-height: 18px;\n"
"}\n\n"
"/* I want to select everything but these comments */\n\n"
".class-2 {\n"
" background-color: rgb(40, 40, 40);\n"
" border: 1px solid rgb(20, 20, 20);\n"
" padding: 10px 15px 10px 15px;\n"
"}\n\n"
"/* Single line */\n\n"
"/* Multiline\n"
" Comment */\n\n"
"Some text here")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.