import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<iframe[\\s\\w=\"\\/]*src=\"(?<src>(?:https*:\\/\\/)?www\\.youtube(?:-nocookie)?\\.com\\/embed\\/(?<vid>[-a-zA-Z0-9@:;%_+.~#&=]+)\\??(?<params>[-a-zA-Z0-9@:;%_+.~#?&\\/=]*))\"[^>]*>(?:<\\/iframe>)?$";
final String string = "<iframe src=\"https://www.youtube.com/embed/lfLRV19y6hg?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/3xzCyOdf4Qc?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/JtpT4LLxFv4?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"440\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/R6UAHzmxJ_g?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/DIFGObcX9A4?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/HtDEqzAk_48?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe src=\"https://www.youtube.com/embed/n5GpN1Xa4q0?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n\n"
+ "<iframe id=\"ytplayer\" type=\"text/html\" width=\"720\" height=\"405\" src=\"https://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&cc_load_policy=1&disablekb=1&enablejsapi=1&modestbranding=1&playsinline=1&rel=0&showinfo=0&color=white\"\n"
+ "frameborder=\"0\" allowfullscreen>\n\n"
+ "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/Hb9-Bvne_gQ\" frameborder=\"0\" allow=\"autoplay; encrypted-media\" allowfullscreen></iframe>\n\n"
+ "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube-nocookie.com/embed/Hb9-Bvne_gQ?rel=0\" frameborder=\"0\" allow=\"autoplay; encrypted-media\" allowfullscreen></iframe>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}