// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<iframe[\s\w="\/]*src="(?<src>(?:https*:\/\/)?www\.youtube(?:-nocookie)?\.com\/embed\/(?<vid>[-a-zA-Z0-9@:;%_+.~#&=]+)\??(?<params>[-a-zA-Z0-9@:;%_+.~#?&\/=]*))"[^>]*>(?:<\/iframe>)?$"#).unwrap();
let string = "<iframe src=\"https://www.youtube.com/embed/lfLRV19y6hg?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>
<iframe src=\"https://www.youtube.com/embed/3xzCyOdf4Qc?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>
<iframe src=\"https://www.youtube.com/embed/JtpT4LLxFv4?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"440\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>
<iframe src=\"https://www.youtube.com/embed/R6UAHzmxJ_g?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>
<iframe src=\"https://www.youtube.com/embed/DIFGObcX9A4?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>
<iframe src=\"https://www.youtube.com/embed/HtDEqzAk_48?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>
<iframe src=\"https://www.youtube.com/embed/n5GpN1Xa4q0?disablekb=1&rel=0&showinfo=0\" width=\"780\" height=\"439\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>
<iframe id=\"ytplayer\" type=\"text/html\" width=\"720\" height=\"405\" src=\"https://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&cc_load_policy=1&disablekb=1&enablejsapi=1&modestbranding=1&playsinline=1&rel=0&showinfo=0&color=white\"
frameborder=\"0\" allowfullscreen>
<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/Hb9-Bvne_gQ\" frameborder=\"0\" allow=\"autoplay; encrypted-media\" allowfullscreen></iframe>
<iframe width=\"560\" height=\"315\" src=\"https://www.youtube-nocookie.com/embed/Hb9-Bvne_gQ?rel=0\" frameborder=\"0\" allow=\"autoplay; encrypted-media\" allowfullscreen></iframe>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}