using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:\d*?-){4}\d*$)(?=(?:-*?\d){10}-*$).{14}$";
string input = @"0-04-44-04-045
0--4-44-04-045
0004-44-04-045
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}