$re = '/^(?=(?:\d*?-){4}\d*$)(?=(?:-*?\d){10}-*$).{14}$/m';
$str = '0-04-44-04-045
0--4-44-04-045
0004-44-04-045
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);