const regex = /^(?=(?:\d*?-){4}\d*$)(?=(?:-*?\d){10}-*$).{14}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\d*?-){4}\\d*$)(?=(?:-*?\\d){10}-*$).{14}$', 'gm')
const str = `0-04-44-04-045
0--4-44-04-045
0004-44-04-045
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}