#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\/page-title\/?\??(?!(.+\/)|-)).+"
Local $sString = "/page-title" & @CRLF & _
"/page-title/" & @CRLF & _
"/page-title?" & @CRLF & _
"/page-title/?" & @CRLF & _
"/page-title?foo" & @CRLF & _
"/page-title/?foo=bar" & @CRLF & _
"" & @CRLF & _
"/page-title/foo/" & @CRLF & _
"/page-title-foo-bat"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")