$re = '/^(?=\/page-title\/?\??(?!(.+\/)|-)).+/m';
$str = '/page-title
/page-title/
/page-title?
/page-title/?
/page-title?foo
/page-title/?foo=bar
/page-title/foo/
/page-title-foo-bat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);