re = /^(?=\/page-title\/?\??(?!(.+\/)|-)).+/m
str = '/page-title
/page-title/
/page-title?
/page-title/?
/page-title?foo
/page-title/?foo=bar
/page-title/foo/
/page-title-foo-bat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end