package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\/]+\/statistics\/?(?:[^\/]+\/?)*$`)
var str = `folder1/statistics
folder1/statistics/test1
folder1/statistics/test1/test2
folder1/statistics/test1/test2/test3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}