re = /^[^\/]+\/statistics\/?(?:[^\/]+\/?)*$/m
str = 'folder1/statistics
folder1/statistics/test1
folder1/statistics/test1/test2
folder1/statistics/test1/test2/test3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end