$re = '/^[^\/]+\/statistics\/?(?:[^\/]+\/?)*$/m';
$str = 'folder1/statistics
folder1/statistics/test1
folder1/statistics/test1/test2
folder1/statistics/test1/test2/test3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);