import re
regex = re.compile(r"^/folder1/statistics\/?(?:[^\/]+\/?)*$", flags=re.MULTILINE)
test_str = ("folder1/statistics\n"
"folder1/statistics/test1\n"
"folder1/statistics/test1/test2\n"
"folder1/statistics/test1/test2/test3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")