using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<!DOCTYPE html>.+?<body>(?-s)";
string input = @"<!DOCTYPE html>
<meta charset=""utf-8"">
<meta name=""generator"" content=""pandoc"">
<meta name=""viewport"" content=""width=device-width, initial-scale=1.0, user-scalable=yes"">
<title></title>
<style>code{white-space: pre;}</style>
<![endif]-->;
<body>
afterwards";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}