// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<!DOCTYPE html>.+?<body>(?-s)").unwrap();
let string = "<!DOCTYPE html>
<meta charset=\"utf-8\">
<meta name=\"generator\" content=\"pandoc\">
<meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0, user-scalable=yes\">
<title></title>
<style>code{white-space: pre;}</style>
<![endif]-->;
<body>
afterwards";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}