$re = '~(?s)<!DOCTYPE html>.+?<body>(?-s)~';
$str = '<!DOCTYPE html>
<meta charset="utf-8">
<meta name="generator" content="pandoc">
<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=yes">
<title></title>
<style>code{white-space: pre;}</style>
<![endif]-->;
<body>
afterwards';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);