import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9.]+)(?:\\n)?";
final String string = "0.11\n"
+ "0220550\n"
+ "5050\n"
+ "505050\n"
+ "5050\n"
+ "505\n"
+ "693\n\n"
+ "96969969969\n"
+ "32.33.3.3\n"
+ "5.55.";
final String subst = "Code Goes Here $1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}