use strict;
my $str = '0.11
0220550
5050
505050
5050
505
693
96969969969
32.33.3.3
5.55.';
my $regex = qr/([0-9.]+)(?:\n)?/mp;
my $subst = 'Code Goes Here $1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";