// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9.]+)(?:\n)?").unwrap();
let string = "0.11
0220550
5050
505050
5050
505
693
96969969969
32.33.3.3
5.55.";
let substitution = "Code Goes Here $1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}