#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<oddInstance>\K<oddInstance>(?=(?:<oddInstance><oddInstance>)*$)"
Local $sString = "<oddInstance><oddInstance><oddInstance><oddInstance><oddInstance><oddInstance>"
Local $sSubst = "<evenInstance>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)