$re = '/<oddInstance>\K<oddInstance>(?=(?:<oddInstance><oddInstance>)*$)/m';
$str = '<oddInstance><oddInstance><oddInstance><oddInstance><oddInstance><oddInstance>';
$subst = "<evenInstance>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;