const regex = /<oddInstance>\K<oddInstance>(?=(?:<oddInstance><oddInstance>)*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<oddInstance>\\K<oddInstance>(?=(?:<oddInstance><oddInstance>)*$)', 'gm')
const str = `<oddInstance><oddInstance><oddInstance><oddInstance><oddInstance><oddInstance>`;
const subst = `<evenInstance>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);