using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[(\{\{.+?\}\}|[^^{}]+)\^(.+?)\]\]";
string input = @"Example String: [[{{hello^test}}|{{goodbye}}]]
Expected Match: False because i want to only match the ^ if it's part of the outside part of the string surrounded by [[ ]] not if it's inside the {{ }}
Example String: [[{{hello^test}}^{{goodbye}}]]
Expected Match: True because both sides of the ^ inside [[ ]] match, ignoring what is inside the {{ }}
Example String: [[{{hello^test}}^{{goodbye^test}}]]
Expected Match: True because again the ^ is between the two parts in {{ }} and needs to ignore what is inside {{ }}
Example String: [[{{hello^test}}|{{goodbye^test}}]]
Expected Match: False because there is no ^ inside the [[ ]] only inside the {{ }} which should be ignored
[[{{6^-2}}x{{6^3}}|{{6^-2}}]]
[[{{6^-2}}x{{6^3}}^{{6^-2}}]]
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}