import Foundation
let pattern = #"\[\[(\{\{.+?\}\}|[^^{}]+)\^(.+?)\]\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Example String: [[{{hello^test}}|{{goodbye}}]]
Expected Match: False because i want to only match the ^ if it's part of the outside part of the string surrounded by [[ ]] not if it's inside the {{ }}
Example String: [[{{hello^test}}^{{goodbye}}]]
Expected Match: True because both sides of the ^ inside [[ ]] match, ignoring what is inside the {{ }}
Example String: [[{{hello^test}}^{{goodbye^test}}]]
Expected Match: True because again the ^ is between the two parts in {{ }} and needs to ignore what is inside {{ }}
Example String: [[{{hello^test}}|{{goodbye^test}}]]
Expected Match: False because there is no ^ inside the [[ ]] only inside the {{ }} which should be ignored
[[{{6^-2}}x{{6^3}}|{{6^-2}}]]
[[{{6^-2}}x{{6^3}}^{{6^-2}}]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)