package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[(\{\{.+?\}\}|[^^{}]+)\^(.+?)\]\]`)
var str = `Example String: [[{{hello^test}}|{{goodbye}}]]
Expected Match: False because i want to only match the ^ if it's part of the outside part of the string surrounded by [[ ]] not if it's inside the {{ }}
Example String: [[{{hello^test}}^{{goodbye}}]]
Expected Match: True because both sides of the ^ inside [[ ]] match, ignoring what is inside the {{ }}
Example String: [[{{hello^test}}^{{goodbye^test}}]]
Expected Match: True because again the ^ is between the two parts in {{ }} and needs to ignore what is inside {{ }}
Example String: [[{{hello^test}}|{{goodbye^test}}]]
Expected Match: False because there is no ^ inside the [[ ]] only inside the {{ }} which should be ignored
[[{{6^-2}}x{{6^3}}|{{6^-2}}]]
[[{{6^-2}}x{{6^3}}^{{6^-2}}]]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}