package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(t)(?:hru|rough)\b`)
var str = `trough
thru`
var substitution = "$1hrough"
fmt.Println(re.ReplaceAllString(str, substitution))
}