const regex = /\b(t)(?:hru|rough)\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(t)(?:hru|rough)\\b', 'gi')
const str = `trough
thru`;
const subst = `$1hrough`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);