use strict;
my $str = 'Rake (100) Pot (1000) Players (andy: 10, bob: 20, cindy: 70)';
my $regex = qr/(?:^Rake \(([0-9]+)\) Pot \(([0-9]+)\) Players \(|)(\w+):?\s*(\d+)(?=[^()]*\))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";