$re = '/(?:^Rake \(([0-9]+)\) Pot \(([0-9]+)\) Players \(|)(\w+):?\s*(\d+)(?=[^()]*\))/m';
$str = 'Rake (100) Pot (1000) Players (andy: 10, bob: 20, cindy: 70)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;